Silverlight 要求使用更新版本

最近下了别人一个小例子,没想到运行它的项目就要求我下载最新silverlight, 之前也搜索过怎么解决,应该是开发版本要和对应客户端版本一致,但我好像记得如果更新了最新的客户端好像连程序都会跑不起来的(我曾经遇到的是这个情况)。我后来发现其实你改一下TestPage.aspx/html 就可以解决了,真的很方便。

举个例子:4.0.50917.0的版本比我安装的版本要高,所以我运行会提示更新。

这里就要求我更新了。

我把它改改 ,改成4.0.40917.0

哈哈 跑起来了 是不是很简单呢~

posted @ 2011-08-11 07:34  wz2cool  阅读(3010)  评论(4编辑  收藏