flutter 开发记录

以下内容均基于AndroidStudio开发Flutter

1.在安装flutter和dart插件时,可能无法安装,最好是先卸载插件,再重新安装。如果实在不行就翻个墙

2.在flutter项目下,android包下面的代码有错误时,需要重新编译。在命令行,需要将目录切到android包下面,才可以执行./gradlew build,flutter build,./gradlew clean等命令

2021.2.19

3.在AndroidStudio开发Flutter时,需要注意有 a.需要下载Dart SDK并配置环境变量 b.需要下载Flutter SDK并配置环境变量 c.在AndroidStudio中配置相应的SDK Path d.当项目中package无法引用时,需要执行命令flutter packages get命令(Target of URI doesn't exist 'package:flutter/material.dart')

4.在flutter中需要下载dart sdk,可以看下这篇文章 https://www.jianshu.com/p/6d2a4f31a4c7?utm_campaign=haruki

2021.2.20

5.当android studio因为 no device 无法运行模拟器测试,首先运行flutter doctor,把带有红色x号的缺少项先安装了。

6.MediaQuery.of() called with a context that does not contain a MediaQuery.

  这个问题是你在运行app时,直接返回StatelessWidget。需要将重写的StatelessWidget包装成  MaterialApp。

posted on 2020-01-15 10:02  洛易  阅读(104)  评论(0编辑  收藏  举报