安装多个版本的TensorFlow

TensorFlow 2.0测试版在今年春季发布,新版本比1.x版本在易用性上有了很大的提升。但是由于2.0发布还没有多久,现在大部分论文的实现代码都是1.x版本的,所以在学习TensorFlow的过程中同时安装1.x和2.0两个版本是很有必要的。

下面是具体操作

 

首先需要安装Anaconda

然后进入Anaconda prompt(未避免安装失败,最好以管理员身份运行)

 

安装第一个版本的tensorflow:

现在是默认环境,输入要安装的第一个tensorflow版本:pip install tensorflow==版本号

pip install tensorflow==2.0.0b1

安装完成后可用以下命令检查:

conda list

找到tensorflow可查看对应版本:

 

 

安装第二个版本的tensorflow:

创建一个新的环境:conda create -n 环境名

conda create -n tensorflow

安装完成后进入新环境:

activate tensorflow

再安装第二个tensorflow版本:

pip install tensorflow==1.14.0

查看tensorflow版本:

 

查看所安装的所有环境:

conda env list

 

 

安装好了以后怎么使用呢

以PyCharm为例

File -> settings -> project ->选择对应环境下的python解释器即可

 

posted @ 2019-08-02 16:53 孑立的老章鱼 阅读(...) 评论(...) 编辑 收藏