随笔- 165  评论- 85  文章- 39 

Android : Must Override a Superclass Method

Android 在eclipse  import 项目时经常有这个问题,关于@override 标示的错误,好多说法是

“在没有进行设置的情况下,eclipse默认使用java 1.5来编译代码,所以经常会出现这个问题。

解决办法:

选择Window –> Preferences –> Java –> Compiler(mac上是Eclipse –> Preferences –> Java –> Compiler),确认选择的是1.6版本的编译器”

可是我打开一看,居然是1.7的,这应该比1.6高级啊,还有错,郁闷了,只能去掉@override的标示,不管他了~

posted on 2012-04-17 01:59  老Zhan  阅读(1892)  评论(1编辑  收藏