TensorFlow安装教程(ubuntu 18.04)

此教程的硬件条件:

1、Nvidia GPU Geforce390及以上
2、Ubuntu 18.04操作系统
3、Anaconda工具包

如果python版本为3.7及以上,使用如下命令降级到3.6:

conda search python    //搜索可用的python版本,这条命令非必须
conda install python=3.6.7       //安装3.6版本中的最新版
python --version        //查看python版本,如果是3.6.7,那就可以了

接下来,按照下面这个视频的教程一步一步做即可,保证没有任何问题。

带字幕版:https://www.youtube.com/watch?v=vxjbL5iN1XY

无字幕版:https://fzhshared-1252154746.cos.ap-guangzhou.myqcloud.com/How%20To%20Install%20Tensorflow-GPU%20(1.8)%20on%20Ubuntu%2018.04.mp4

视频中的命令:https://github.com/markjay4k/Install-Tensorflow-on-Ubuntu-17.10-/blob/master/Tensorflow%20Install%20instructions.ipynb

其中,有一条命令不能按照视频中的来,视频中是:

 

conda create -n tf python=3.6 pip
source activate tf
pip install tensorflow-gpu==1.5

 

替换为:

conda create -n tensorflow python=3.6.7 anaconda #tensorflow写成tf也没关系。
source activate tensorflow #对应上面的参数-n的值。如果写成tf,那么这里就是tf
conda install -c conda-forge tensorflow-gpu #安装tensorflow。第一条指令不是安装,这条才是

如果在Terminal中可以正常使用tensorflow,但是在pycharm中出现“libcudnn.so.*找不到文件“的情况,解决办法是,在pycharm中点击【Run】选项卡,选择【Edit Configurations】,找到”Environment Variables“(环境变量),添加环境变量:

Name: LD_LIBRARY_PATH
Value: /usr/local/cuda/lib64:$LD_LIBRARY_PATH

 

posted @ 2018-12-30 13:50 fuzhihong0917 阅读(...) 评论(...) 编辑 收藏