HDU 2577 How to Type

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
Sample Input
3
Pirates
HDUacm
HDUACM
Sample Output
8
8
8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
分析: 用两个a,b数组分别记录Caps Lock开与关时打印第i个字母的最少操作步骤;
    而对于第i个字母的大小写还要分开讨论:
    Ch[i]为小写: a[i]=min(a[i-1]+1,b[i-1]+2);不开灯直接字母,开灯则先关灯再按字母,最后保持不开灯; 
b[i]=min(a[i-1]+2,b[i-1]+2);不开灯则先按字母再开灯,开灯则Shift+字母(比关灯,按字母再开灯节省步数),最后保持开灯;
    Ch[i]为大写: a[i]=min(a[i-1]+2,b[i-1]+2); b[i]=min(a[i-1]+2,b[i-1]+1);
    最后,b[len-1]++,关灯嘛!    
code:
View Code
#include<stdio.h>
#include<string.h>
#define min(a,b)((a)<(b))?(a):(b)
int main()
{
char s[101];
int a[100];
int b[100];
int i,t,len;
scanf("%d",&t);
while(t--)
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
scanf("%s",s);
len=strlen(s);
if(s[0]>='a'&&s[0]<='z')
{
a[0]=1;b[0]=2;
}
else
{
a[0]=2;b[0]=2;
}
for(i=1;i<len;i++)
{
if(s[i]>='a'&&s[i]<='z')
{
a[i]=min(a[i-1]+1,b[i-1]+2);
b[i]=min(a[i-1]+2,b[i-1]+2);
}
else
{
a[i]=min(a[i-1]+2,b[i-1]+2);
b[i]=min(a[i-1]+2,b[i-1]+1);
}
}
b[len-1]++;
printf("%d %d\n",a[len-1],b[len-1]);
printf("%d\n",min(a[len-1],b[len-1]));
}
return 0;
}

 
posted @ 2012-03-14 18:01  'wind  阅读(542)  评论(0编辑  收藏  举报