HDU 2844 Coins 【多重背包*】

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4
分析:多重背包的第二种,给定一个区间,判断这个区间范围内有多少背包能够装满。
code:
#include<stdio.h>
#include<string.h>
int f[100001];
int main()
{
int i,j,k,n,m,v,tot;
int a[101];
int b[101];
while(scanf("%d%d",&n,&v),n||v)
{
for(i=0;i<n;i++)
scanf("%d",&a[i]);
for(i=0;i<n;i++)
scanf("%d",&b[i]);
memset(f,0,sizeof(f));
f[0]=1;
tot=0;
for(i=0;i<n;i++)
{
if(a[i]*b[i]>=v)
{
for(j=a[i];j<=v;j++)
if(f[j-a[i]]&&!f[j])
{f[j]=1;tot++;}
continue;
}
k=1;
while(k<b[i])
{
for(j=v;j-k*a[i]>=0;j--)
if(f[j-k*a[i]]&&!f[j])
{f[j]=1;tot++;}
b[i]-=k;
k<<=1;
}
for(j=v;j-a[i]*b[i]>=0;j--)
if(f[j-a[i]*b[i]]&&!f[j])
{f[j]=1;tot++;}
}
printf("%d\n",tot);
}
return 0;
}


 
posted @ 2012-03-14 14:06  'wind  阅读(447)  评论(0编辑  收藏  举报