第十二周作业
这个作业属于哪个课程 C语言程序设计II
这个作业要求在哪里 掌握(1)二级指针的概念,以及指针数组的应用;(2)了解指针与函数的关系,掌握指针作为函数返回值;(3)掌握单向链表的概念和操作(建立、增加、删除、修改、遍历)
我在这个课程的目标是 我希望能够通过学习C语言的知识,编写程序
这个作业在哪个具体方面帮助我实现目标 数组指针,指针函数,函数指针,指针数组
参考文献 https://www.runoob.com/cprogramming/c-arrays.html
6-1 计算最长的字符串长度 (15 分)
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。

函数接口定义:

int max_len( char *s[], int n );

其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。

裁判测试程序样例:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXN 10
#define MAXS 20

int max_len( char *s[], int n );

int main()
{
    int i, n;
    char *string[MAXN] = {NULL};

    scanf("%d", &n);
    for(i = 0; i < n; i++) {
        string[i] = (char *)malloc(sizeof(char)*MAXS);
        scanf("%s", string[i]);
    }
    printf("%d\n", max_len(string, n));

    return 0;
}

/* 你的代码将被嵌在这里 */
输入样例:

4

blue

yellow

red

green

输出样例:

6

代码:

int max_len( char *s[], int n )
{
    int max=0;
    int i;
    for(i=0;i<n;i++){
        if(strlen(s[i])>strlen(s[max]))

        max=i;
    }

return strlen(s[max]);
}


之前错误原因就是把函数名len打成了strlen
思路:就是用for循环来判断最大长度,如果指针数组第i项长度大于之前最大长度max,就继续吧i赋值给max。

6-2 统计专业人数 (15 分)
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:

struct ListNode {
char code[8];
struct ListNode *next;
};

这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。

函数接口定义:

int countcs( struct ListNode *head );

其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct ListNode {
    char code[8];
    struct ListNode *next;
};

struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );

int main()
{
    struct ListNode  *head;

    head = createlist();
    printf("%d\n", countcs(head));
    
    return 0;
}

/* 你的代码将被嵌在这里 */
输入样例:
1021202

2022310

8102134

1030912

3110203

4021205

输出样例:
3

代码:

int countcs(struct ListNode *head)
{
    int count=0;
    for(int i=0;head!=NULL;i++)
    {
        if((*head).code[1]=='0'&&(*head).code[2]=='2')
        count++;
        head=head->next;
    }
    return count;
}


这里需要注意的就是结构体格式不要忘记了还有字符符号‘’

6-3 删除单链表偶数节点 (20 分)
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:

struct ListNode {
int data;
struct ListNode *next;
};

函数接口定义:

struct ListNode createlist();
struct ListNode deleteeven( struct ListNode *head );

函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。

裁判测试程序样例:


#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
     struct ListNode *p = head;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    struct ListNode *head;

    head = createlist();
    head = deleteeven(head);
    printlist(head);

    return 0;
}

/* 你的代码将被嵌在这里 */
输入样例:
1 2 2 3 4 5 6 7 -1

输出样例:
1 3 5 7

代码:

struct ListNode *createlist(){
struct ListNode * p ,*tail,*head=NULL;
    int size = sizeof (struct ListNode);
    int n,i;
    scanf("%d",&n);
    for (i=0;n!=-1;i++)
    {
        
        p=(struct ListNode *) malloc(size);
        p->data = n;
        
        if(head==NULL){
            head=p;
            tail=p;
        }
        else {
            tail->next = p;
        }
        tail = p;
        
        
        
        scanf("%d",&n);
    }
    p->next=NULL;
    
    return head;
} 
struct ListNode *deleteeven( struct ListNode *head )
{
    struct ListNode *p,*part1,*part2;


    
    while(head && head->data %2 ==0){ 
        part1=head;
        head = head->next;
        free(part1);
    }
    part1=head;
    while(part1 && part1 ->next !=NULL) 
    {
        while(part1->next && part1->next->data%2==0)
        {   
            part2=part1->next;
            part1->next=part2->next;  
        }
        part1=part1->next;
    }
    return head;
}

参考链接:
https://blog.csdn.net/weixin_44061561/article/details/85732857
head && head->data%2==0 //保证头结点不是偶数
p = head;
head = head->next;
free(p); //head空指针或者指向一个奇数节点,外层循环判断到结尾,内层循环连续删除

posted on 2019-05-17 22:33  Mi_Yun  阅读(150)  评论(0编辑  收藏  举报