0-1背包的总结

      HDU 2602       Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 30300    Accepted Submission(s): 12477


Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

 

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 
Sample Output
14
 
 题意:t组测试数据,每组先输入n, m, 代表物品的种类和背包的大小。 接下来两行,每行n个数,第一行代表价值;第二行代表花费。每件物品只能用一次!
      输出背包所能装下的最大价值!
   
     代码(一):
     
// 0-1背包模板题

#include <stdio.h>
#include <string.h>
int w[1002], c[1002];
int dp[1002][1002];

int max(int a, int b)
{
    return a>b?a:b;
}

int main()
{
    int t;
    int i, j;
    scanf("%d", &t);
    int n, m;
    while(t--)
    {
        scanf("%d %d", &n, &m);
        for(i=1; i<=n; i++)
        {
            scanf("%d", &w[i] );
        }
        for(i=1; i<=n; i++)
        {
            scanf("%d", &c[i] );
        }
        for(i=0; i<=n; i++)
            dp[i][0]=0;
        for(j=0; j<=m; j++)
            dp[0][j]=0;
        for(i=1; i<=n; i++ )
        {
            for(j=0; j<=m; j++)
            {
                dp[i][j] = dp[i-1][j];
                if( j>=c[i] )
                  dp[i][j] = max(dp[i-1][j], dp[i-1][j-c[i]]+w[i] );
            }
        }
        printf("%d\n", dp[n][m] );
    }
    return 0;
}

    代码(二)(刘汝佳的书上写的):

 

// 0-1背包模板题

#include <stdio.h>
#include <string.h>
int w[1002], c[1002];
int dp[1002][1002];

int max(int a, int b)
{
    return a>b?a:b;
}

int main()
{
    int t;
    int i, j;
    scanf("%d", &t);
    int n, m;
    while(t--)
    {
        scanf("%d %d", &n, &m);
        for(i=1; i<=n; i++)
        {
            scanf("%d", &w[i] );
        }
        for(i=1; i<=n; i++)
        {
            scanf("%d", &c[i] );
        }
        for(i=0; i<=n; i++)
            dp[i][0]=0;
        for(j=0; j<=m; j++)
            dp[0][j]=0;
        for(i=1; i<=n; i++ )
        {
            for(j=0; j<=m; j++)
            {
                dp[i][j] = (i==1?0:dp[i-1][j] );
                if( j>=c[i] )
                  dp[i][j] = max(dp[i][j], dp[i-1][j-c[i]]+w[i] );
            }
        }
        printf("%d\n", dp[n][m] );
    }
    return 0;
}

   

posted @ 2014-08-27 16:06  我喜欢旅行  阅读(218)  评论(0编辑  收藏  举报