OpenSUSE+Eclipse+Aptana+Air的安装过程全纪录

对于Linux,我一直是个新手,总是搞不懂为什么会有那么多不一致。哪些环境变量又需要修改?因此我用Mono开发最常用的就是已经配置好的VM虚拟机,不用我操心安装的问题。

这个周末鬼使神差的想搞一个Adobe Air试试,一路磕磕碰碰,把过程记录下来备查:(我用的环境是OpenSUSE 11.1)

  1. 第一步下载 Adobe AIR runtime环境并安装,这个很顺利,直接下载,直接运行就可以安装。不过安装需要root权限,这个问题不大。搞定
  2. 安装Java VM,我用YAST安装了Java 1.6,很顺利,我喜欢Linux的这种即需即装的模式。
  3. 下载AIR开发环境,根据我一般习惯我选择了Aptana,刚开始下载的是独立运行版本。解压后直接运行,报错,VM 终止,ExitCode=127。到Google兜了一圈,这个问题老外也提出过,不过解决的方法五花八门,我试了几个无效。估计是JVM配置问题。再试试其他途径吧。Aptana在Eclipse中也可以已插件运行。
  4. 安装Eclipse,这次我在Yast中发现了它,用它比较保险,实在对Linux安装缺乏信心。还好,经过漫长的下载。成功安装。
  5. 根据Aptana的提示,在Eclipse的自动更新中可以自动下载Aptana插件。进入Eclipse->Help->Software Update, 更新界面不能打开,报错,“Can not lanuch updater UI ”,Google告诉我,原因不知道,但是我可以选择重新安装或者选择配置一个“Classic Update”,方法是 Preferences -> General > Capabilites-> check the Classic Update box.
  6. 我选择了后者,很快,Eclipse可以更新了,Help -> Software Updates > Find and Install... -> Search for new features to install ->New Remote Site... ->输入更新Site http://update.aptana.com/install/studio/3.4
  7. 更新界面打开了,但是,等等,还是报错,错误是版本不匹配。Aptana提示它的插件需要Eclipse 3.4.1,而我安装的Eclipse 3.4.0,看来Yast没有提供最新的版本更新,无奈,只好下载一个下载Eclipse 3.4.1 ,现在Eclipse已经有3.4.2版本,但是我怕有版本冲突,还是保险一点下个3.4.1
  8. 解压缩,运行,执行更新,Ok成功。更新为Aptana,接着更新Air,经过漫长的下载,但是好在一路顺利,终于,我在Eclipse的界面里看到了Air的Project。

 

posted @ 2009-05-24 22:02 行知 阅读(...) 评论(...) 编辑 收藏