I - Crossing River

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

有两种过河方法

1.让最小的那个人一直来回载人过去
2.一群人过河,让最小的两个人过去,然后最小的人过来,还没过去的最大两个人过去,第二小的人在回来;一直重复;
最后比较两种方法那个更好
分情况讨论,小于4人可以直接找到方法;
要是大于4人,把四个人放在一组,然后比较两种方法运人哪个更快,然后选快的那种;
不可以所有人都用同一种方法如何在比较,这样还是太慢了

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<cmath>
#include<string.h>
#include<algorithm>
#define sf scanf
#define pf printf
#define cl clear()
#define pb push_back
#define mm(a,b) memset((a),(b),sizeof(a))
#include<vector>
const double pi=acos(-1.0);
typedef __int64 ll;
typedef long double ld;
const ll mod=1e9+7;
using namespace std;
int main()
{
	int re;
	int a[1005];
	cin>>re;
	while(re--)
	{
		mm(a,0);
		int n;
		cin>>n;
		for(int i=0;i<n;i++)
		{
			cin>>a[i];
		}
		sort(a,a+n);
		int sum=0;
		int num=n/2;
		while(n>3)
		{
			int sum1=0,sum2=0;
			sum1=a[0]+2*a[1]+a[n-1];
			sum2=a[0]*2+a[n-1]+a[n-2];
			sum+=sum1<sum2?sum1:sum2;
			n-=2;
		}
		if(n==1)
		sum+=a[0];
		else if(n==2)
		sum+=a[1];
		else if(n==3)
		sum+=a[0]+a[1]+a[2];
		pf("%d\n",sum);
	}
	return 0;
}
posted @ 2018-07-22 21:56  一无所知小白龙  阅读(143)  评论(0编辑  收藏  举报