PHP IDE PHPStorm配置支持友好Laravel代码提示方法

PHPStorm神器可以支持更友好的laravel框架代码提示(点击查看),只需要执行如下才做:
第一步:在项目的composer.json中添加如下一行

代码如下:

"require": {
"laravel/framework": "5.0.*",
"barryvdh/laravel-ide-helper":"dev-master"
}

 


第二步:执行composer update


第三步:添加service provider,打开项目config/app.php 于providers添加如下一行:

代码如下:

'Barryvdh\LaravelIdeHelper\IdeHelperServiceProvider',

 


第四步:执行 

php artisan clear-compiled
php artisan ide
-helper:generate
php artisan optimize

 


第五步:修改composer.json,添加一行

代码如下:

"post-update-cmd": [
"php artisan clear-compiled",
"php artisan optimize",
"php artisan ide-helper:generate"
 
]

 


看看效果:

 

 

posted @ 2015-10-19 17:35 午时的海 阅读(...) 评论(...) 编辑 收藏