POJ-3481 Double Queue (splay)

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0 The system needs to stop serving
1 K P Add client K to the waiting list with priority P
2 Serve the client with the highest priority and drop him or her from the waiting list
3 Serve the client with the lowest priority and drop him or her from the waiting list
Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input
Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output
For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input
2
1 20 14
1 30 3
2
1 10 99
3
2
2
0
Sample Output
0
20
30
10
0

题意:有三种操作

1:加入一个数,给出它的权值,把它放入队列中,

2:弹出权值最大的数

3:弹出权值最小的数

代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define maxn 100010
using namespace std;

struct splaytree
{
    int size,root;
    int son[maxn][2],fa[maxn],key[maxn],pos[maxn];
    void init()
    {
        size=root=0;
        son[0][0]=son[0][1]=0;
    }
    void newnode(int &rt,int father,int val,int id)
    {
        rt=++size;
        son[rt][0]=son[rt][1]=0;
        fa[rt]=father;
        key[rt]=val;
        pos[rt]=id;
    }
    void rotate(int x,int kd)
    {
        int y=fa[x];
        son[y][!kd]=son[x][kd];
        fa[son[x][kd]]=y;
        fa[x]=fa[y];
        if(fa[y])
        {
            son[fa[y]][son[fa[y]][1]==y]=x;
        }
        son[x][kd]=y;
        fa[y]=x;
    }
    void splay(int x,int to)
    {
        while(fa[x]!=to)
        {
            if(son[fa[x]][0]==x)
            {
                rotate(x,1);
            }
            else
            {
                rotate(x,0);
            }
        }
        if(!to)
        {
            root=x;
        }
    }
    void insert(int val,int id)
    {
        int x;
        for(x=root; son[x][key[x]<val]; x=son[x][key[x]<val]);
        newnode(son[x][key[x]<val],x,val,id);
        splay(son[x][key[x]<val],0);
    }
    void Delete(int x)
    {
        if(x==root)
        {
            if(!son[x][0]&&!son[x][1])
            {
                init();
            }
            else
            {
                int t=son[x][0]?0:1;
                fa[son[x][t]]=0;
                root=son[x][t];
            }
        }
        else
        {
            int y,t;
            y=fa[x];
            t=(son[y][1]==x);
            son[y][t]=son[x][!t];
            fa[son[x][!t]]=y;
            splay(y,0);
        }
    }
    void lowest()
    {
        int x=root;
        if(x)
        {
            for(; son[x][0]; x=son[x][0]);
            printf("%d\n",pos[x]);
            Delete(x);
        }
        else
        {
            puts("0");
        }
    }
    void highest()
    {
        int x=root;
        if(x)
        {
            for(; son[x][1]; x=son[x][1]);
            printf("%d\n",pos[x]);
            Delete(x);
        }
        else
        {
            puts("0");
        }
    }
} tree;

int main()
{
    int op,val,id;
    tree.init();
    while(scanf("%d",&op),op)
    {
        if(op==1)
        {
            scanf("%d%d",&id,&val);
            tree.insert(val,id);
        }
        else
        {
            if(op==2)
            {
                tree.highest();
            }
            else
            {
                tree.lowest();
            }
        }
    }
    return 0;
}

 

 

posted @ 2017-12-24 20:14  Styx-ferryman  阅读(590)  评论(0编辑  收藏  举报