12577 - Hajj-e-Akbar

 

 Hajj-e-Akbar 

 

Labayk Allahuma Labayk. Labayk La shareeka lakaLabayk. Innal hamda wannimata laka wal mulk. Lashareeka Lak

 

(Here I am at your service, oh Lord, here I am - here Iam. No partner do you have. Here I am. Truly, the praiseand the favor are yours, and the dominion. No partner doyou have.)

These are the words chanted by some two million peoplefrom world heading, as if pulled by a magnet, to onesingle spot on Earth. As has happened every year for 14 centuries, Muslim pilgrims gather inMakkah to perform rituals based on those conducted by the Prophet Muhammad during hislast visit to the city.

 

\epsfbox{p12577.eps}

Performing these rituals, known as the Hajj, is the fifth pillar of Islam and the mostsignificant manifestation of Islamic faith and unity. Undertaking the Hajj at least once is aduty for Muslims who are physically and financially able to make the journey to Makkah.The emphasis on financial ability is meant to ensure that a Muslim takes care of his familyfirst. The requirement that a Muslim be healthy and physically capable of undertaking thepilgrimage is intended to exempt those who cannot endure the rigors of extended travel.

The pilgrimage is the religious high point of a Muslim's life and an event that every Muslimdreams of undertaking. Umrah, the lesser pilgrimage, can be undertaken at any time of theyear; Hajj, however, is performed during a five-day period from the ninth through thethirteenth of Dhu Al-Hijjah, the twelfth month of the Muslim lunar calendar.

It is generally presumed that the Hajj performed on Friday is called `Hajj-e-Akbar' and it is asuperior kind of Hajj as compared with the Hajj performed on other days of the week.

But, the correct meaning of the term, as explained by a large number of the commentators ofthe Holy Quran is that the Umrah, which can be performed at any time throughout the year,was generally called `Hajj-e-Asghar' (the minor Hajj). In order to distinguish hajj fromUmrah the former was named `Hajj-e-Akbar' (the greater hajj). Therefore, each and everyhajj is Hajj-e-Akbar, no matter whether it is performed on Friday or on any other day. Theword `Akbar' (greater) is used only to distinguish it from Umrah which is a minor Hajj.

 

Input 

There will be several lines in the input terminated with a line containing a single ` *'. This lastline should not be processed. Each of the lines will contain either Hajj or Umrah.

 

Output 

For each line of the input, output either ` Hajj-e-Akbar' or ` Hajj-e-Asghar' in separate lineswithout quotations. For exact format refer to the sample.

 

Sample Input 

 

Hajj
Umrah
Hajj
Umrah
*

 

Sample Output 

 

Case 1: Hajj-e-Akbar
Case 2: Hajj-e-Asghar
Case 3: Hajj-e-Akbar
Case 4: Hajj-e-Asghar

 

#include<stdio.h>
int main()
{
	char s[6];
	int count=1;
	while(gets(s))
	{
		if(s[0]=='*') break;
		if(s[0]=='H') printf("Case %d: Hajj-e-Akbar\n",count++);
		else printf("Case %d: Hajj-e-Asghar\n",count++);
	}
	return 0;
}


posted @ 2013-06-15 14:55  爱生活,爱编程  阅读(260)  评论(0编辑  收藏  举报