Try Again

HDU 1171 Big Event in HDU

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41949    Accepted Submission(s): 14421


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

 

Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1
 

 

Sample Output
20 10
40 40
杭电计算机学院和软件学院分家,问尽量平分,且第一个输出大于等于第二个输出
多重背包问题
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
#define lowbit(x) (x&(-x))
#define max(x,y) (x>y?x:y)
#define min(x,y) (x<y?x:y)
#define MAX 100000000000000000
#define MOD 1000000007
#define PI 3.141592653589793238462
#define INF 1000000000
#define mem(a) (memset(a,0,sizeof(a)))
typedef long long ll;
ll dp[500006];
ll n,v,m,x,y,vis[100006];
ll ans,pos;
int main()
{
    while(scanf("%lld",&n)&& n>0)
    {
        ans=pos=0;
        mem(dp);
        for(int i=0;i<n;i++)
        {
            scanf("%lld%lld",&x,&y);
            ans+=x*y;
            int t=1;
            while(y>t)
            {
                vis[pos++]=t*x;
                y-=t;
                t*=2;
            }
            vis[pos++]=y*x;
        }
        m=ans/2;
        for(int i=0;i<pos;i++)
        {
            for(int j=m;j>=vis[i];j--)
            {
                dp[j]=max(dp[j],dp[j-vis[i]]+vis[i]);
            }
        }
        if(ans-dp[m]>=dp[m]) printf("%lld %lld\n",ans-dp[m],dp[m]);
        else printf("%lld %lld\n",dp[m],ans-dp[m]);
    }
    return 0;
}

 

posted @ 2017-07-17 10:17  十年换你一句好久不见  阅读(117)  评论(0编辑  收藏  举报