2015北京网络赛 A题 The Cats' Feeding Spots 暴力

The Cats' Feeding Spots

Time Limit: 1 Sec  

Memory Limit: 256 MB

题目连接

http://hihocoder.com/contest/acmicpc2015beijingonline/problem/1

Description

In Yan Yuan, the Peking University campus, there are many homeless cats. They all live happy lives because students founded a Cat Association to take care of them. Students not only feed them, but also treat their illness and sterilize some of them. Students make many feeding spots for the cats and cats always gather around those spots and make a lot of noise at night. Now the university authorities decide to restrict the number of feeding spots. This is the conversation between an officer and Rose Li, the director of Cat Association, and also a ACMer.

"Rose, From now on, you can't build any new feeding spots any more. But I want you to keep exactly N feeding spots, and you should make the area which contains the feeding spots as small as possible!"

"Oh, do you mean that we should find a smallest convex hull which contains N spots?"

"Convex hull? What is a convex hull? Please speak Chinese!"

"All right, forget the convex hull. So what do you mean the 'area', what's its shape?"

"It means... and the shape? Oh... let's do it this way: you can choose any feeding spot as center, and then draw a circle which includes exactly N spots. You should  find the smallest circle of such kind, and then we remove all feeding spots outside that circle."

Although this way sounds a little bit ridiculous, Rose still writes a program to solve the problem. Can you write the program?

Input

The first line is an integer T (T <= 50), meaning the number of test cases.

Then T lines follow, each describing a test case.

For each test case:

Two integer M and N go first(1 <= M, N <= 100), meaning that there are M feeding spots originally and Rose Li has to keep exactly N spots.

Then M pairs of real numbers follow, each means a coordinate of a feeding spot in Yan Yuan. The range of coordinates is between [-1000,1000]

Output

For each test case, print the radius of the smallest circle. Please note that the radius must be an POSITIVE INTEGER and no feeding spots should be located just on the circle because it's hard for the campus gardeners to judge whether they are inside or outside the circle.  If there are no solution, print "-1" instead..

Sample Input

4
3 2 0 0 1 0 1.2 0
2 2 0 0 1 0
2 1 0 0 1.2 0
2 1 0 0 1 0

Sample Output

1
2
1
-1

HINT

 

题意

给你一百个点,找个以这些点为中心的最小的圆,使得这个圆恰好包含了n个点,而且这个圆的边界上并没有点

题解:

暴力枚举就好了,我预处理了每个点之间的距离,然后取第n大的,然后特判一下就好了

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <cmath>

using namespace std;

const int inf=1e9;
const int N=110;
const double eps=1e-8;
struct node
{
    double x,y;
}s[N];
double dis[N][N];
int n,m,T,ans;

inline double dist(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&m,&n);
        ans=inf;
        memset(dis,0,sizeof(dis));
        for(int i=0;i<m;i++)
        {
            scanf("%lf%lf",&s[i].x,&s[i].y);
        }
        if(n>m)
        {
            printf("-1\n");
            continue;
        }
        for(int i=0;i<m;i++)
        {
            for(int j=0;j<m;j++)
            {
                dis[i][j]=dist(s[i],s[j]);
            }
        }
        for(int i=0;i<m;i++)
        {
            sort(dis[i],dis[i]+m);
            int p=(int)ceil(dis[i][n-1]+eps);
            if(dis[i][n]-p>eps||n==m)
                ans=min(ans,p);
        }
        if(ans==inf) ans=-1;
        printf("%d\n",ans);
    }
}

 

posted @ 2015-09-20 20:10  qscqesze  阅读(952)  评论(0编辑  收藏  举报