hdoj--1005--Number Sequence(规律题)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 137047    Accepted Submission(s): 33211



Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
1 1 3 1 2 10 0 0 0
 

Sample Output
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1008 1021 1019 1009 1012


规律题,48一循环

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[48];
int main()
{
	int A,B,n;
	while(scanf("%d%d%d",&A,&B,&n)!=EOF)
	{
		if(A==0&&B==0&&n==0) break;
		memset(a,0,sizeof(a));
		a[2]=a[1]=a[3]=1;
		int t;
		for(int i=3;i<=48;i++)
		a[i]=(A*a[i-1]%7+B*a[i-2]%7)%7;
		printf("%d\n",a[n%48]);
	}
	return 0;
}


posted @ 2015-12-01 15:06  上弦月307  阅读(147)  评论(0编辑  收藏  举报