【快速幂】——hdu1061

                                  Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46398    Accepted Submission(s): 17500


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

 

Output
For each test case, you should output the rightmost digit of N^N.
 

 

Sample Input
2 3 4
 

 

Sample Output
7 6
 
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
 
法一:快速幂取模
 
#include <iostream>
using namespace std;

int qmod(long long a,long long b,long long c)
{
    int ans = 1;
    a%=c;
    while(b>0)
    {
        if(b&1)
        ans = (ans * a) % c;
        b = b>>1;
        a = (a * a) % c;
    }
    return ans;
}

int main()
{
    long long n,t;
    cin>>n;
    while(n--)
    {
        cin>>t;;
        cout<<qmod(t,t,10)<<endl;
    }
    return 0;
}

 

法二:找规律

#include<stdio.h>
int main()
{
    __int64 i,n,s,m;
    while(scanf("%I64d",&n)!=EOF)
    {
    
        while(n--)
        {  
            scanf("%I64d",&m);
            s=m;
            for (i=2;i<=m%4+4;i++)
            {
                s=s*m%10;
            }
            printf("%I64d\n",s);
        }
    }
    return 0;
}

 

posted @ 2016-06-06 11:47  琥珀川||雨露晨曦  阅读(60)  评论(0编辑  收藏  举报