HDOJ 1171 Big Event in HDU

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38607    Accepted Submission(s): 13362


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

 

Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

 

Sample Output
20 10 40 40
 

 

Author
lcy
 

 

Recommend
We have carefully selected several similar problems for you:  2602 1203 2159 2955 2844 

题意:

给出一些互不相同的数以及这些数的个数,把这些数字组合成两个数使得这两个数最接近并且前一个数字大于后一个数字,然后切记最后case结尾是负数不是-1

分析:

我们处理出所有的可以组成的数字然后找出最接近的$\frac {sum}{2}$的数字...

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<bitset>
//by NeighThorn
using namespace std;

int n,a,b;

bitset<500005> s,l;

signed main(void){
	while(scanf("%d",&n)&&n>=0){
		s.reset(),s[0]=1;int sum=0,res;
		for(int i=1,a,b;i<=n;i++){
			scanf("%d%d",&a,&b);
			l.reset();
			for(int j=0;j<=b;j++)
				l|=s<<(a*j);
			s=l;sum+=a*b;
		}
		for(int i=sum/2;i<=sum;i++)
			if(s[i]&&i>=sum-i){
				res=i;
				break;
			}
		printf("%d %d\n",res,sum-res);
	}
	return 0;
}

  


By NeighThorn

posted @ 2017-02-21 11:08  NeighThorn  阅读(153)  评论(0编辑  收藏  举报