北在北方

太白枝头看,花开不计年,杯中浮日月,楼外是青天。
posts - 191, comments - 231, trackbacks - 0, articles - 0

导航

公告

2016年4月20日

摘要: 该方案使用RSA加密和解密。 每次登录前,客户端从服务器端获取公钥和随机值。 公钥用于加密明文; 随机值可以加强每一次操作的安全性,随机值也加入明文中一并加密,服务端对随机值进行校验,校验后从缓存中销毁,这样就算被别人拿到加密后的密文再次发起请求,由于随机值已失效,请求也是无效的。 下面以js客户端阅读全文

posted @ 2016-04-20 20:27 CN.programmer.Luxh 阅读(905) 评论(0) 编辑

2015年12月5日

摘要: 1、参照http://www.cnblogs.com/luxh/p/5016894.html 部署好solr的环境2、在solr_home下建立一个core_item目录[root@iZ23exixsjaZ solr_home]# pwd/luxh/solr/solr_home[root@iZ23e...阅读全文

posted @ 2015-12-05 14:56 CN.programmer.Luxh 阅读(186) 评论(0) 编辑

2015年12月3日

摘要: Ansj的使用和相关资料下载参考:http://iamyida.iteye.com/blog/2220833 参考http://www.cnblogs.com/luxh/p/5016894.html 配置和solr和tomcat的1、从http://iamyida.iteye.com/...阅读全文

posted @ 2015-12-03 19:24 CN.programmer.Luxh 阅读(986) 评论(0) 编辑

摘要: 1、版本选择solr-5.3.1.tgzapache-tomcat-8.0.29.tar.gz2、解压tomcat和solr[root@iZ23exixsjaZ solr]# tar -zxvf apache-tomcat-8.0.29.tar.gz [root@iZ23exixsjaZ solr]...阅读全文

posted @ 2015-12-03 17:06 CN.programmer.Luxh 阅读(240) 评论(0) 编辑

2015年8月2日

摘要: 1、下载node.js 源码包https://nodejs.org/download/2、检查是否安装了python。 要求是python2.6或者python2.6以上版本rpm -qa |grep python 查看python版本 python 如果没有,先安装python3、检查安装配置[...阅读全文

posted @ 2015-08-02 14:05 CN.programmer.Luxh 阅读(97) 评论(0) 编辑

摘要: 1、下载redishttp://redis.io/download2、解压缩、安装[root@iZ944wsnvhcZ local]# tar -zxvf redis-3.0.1.tar.gz [root@iZ944wsnvhcZ local]# cd redis-3.0.1[root@iZ944w...阅读全文

posted @ 2015-08-02 14:04 CN.programmer.Luxh 阅读(109) 评论(0) 编辑

摘要: 参考:http://blog.abv.cn/?p=50阿里云CentOS6默认没有启动iptables1、检查iptables状态[root@iZ94jj63a3sZ ~]# service iptables statusiptables: Firewall is not running.[root...阅读全文

posted @ 2015-08-02 14:03 CN.programmer.Luxh 阅读(110) 评论(0) 编辑

摘要: 参考:http://help.aliyun.com/knowledge_detail/5974154.html?spm=5176.788314850.3.2.hUqwXo1、在阿里云上购买了服务器,又另外买了一块数据盘,这个时候就需要对数据盘进行分区和格式化。2、使用ssh连接到云服务器,查看数据盘...阅读全文

posted @ 2015-08-02 14:03 CN.programmer.Luxh 阅读(96) 评论(0) 编辑

摘要: 操作系统:CentOS6.5 64bitNginx: 1.9.31、下载Nginx[root@iZ94jj63a3sZ softs]# wget http://nginx.org/download/nginx-1.9.3.tar.gz2、安装依赖的库[root@iZ94jj63a3sZ softs]...阅读全文

posted @ 2015-08-02 14:02 CN.programmer.Luxh 阅读(1613) 评论(0) 编辑

2014年12月11日

摘要: 在Node环境下。需要预先安装好Node。1、安装grunt-cli[root@Luxh-01 ~]# npm install -g grunt-cli2、创建一个目录test[root@Luxh-01 ~]# mkdir test3、进入test目录,创建一个package.json文件,内容...阅读全文

posted @ 2014-12-11 21:02 CN.programmer.Luxh 阅读(182) 评论(1) 编辑