HDU 1096 A+B for Input-Output Practice (VIII)

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 155081    Accepted Submission(s): 46820


Problem Description
Your task is to calculate the sum of some integers.
 

 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 

 

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 

 

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
 

 

Sample Output
10
15
6
 

 

Author
lcy
这道题目很坑  卡输出格式   要求输出空行,但最后一行不要求多输出,害的我一直WA
这题目的意思就是求几个数的和,开始是代表有几组数据,以后每一行求一次和,然后输出
#include<stdio.h>
int main()
{
    int n,m,a;
    long long sum;
    while(~scanf("%d",&n))
    {
        int i;
        for(i=0;i<n;i++)
        {
            scanf("%d",&m);
            sum=0;
            while(m--)
            {
                scanf("%d",&a);
                sum += a;
            }
            printf("%lld\n",sum);
            if(i!=n-1)
            printf("\n");
        }
    }
    return 0;
}

 

posted on 2017-03-21 19:47  九月旧约  阅读(184)  评论(0编辑  收藏  举报

导航