POJ 1733 Parity game (HASH+并查集)

Parity game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5168   Accepted: 2028

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

Source

 
 
这是比较经典的一类并查集的题目。
 

解题思路:hash离散化+并查集

首先我们不考虑离散化:s[x]表示(root[x],x]区间1的个数的奇偶性,0-偶数,1-奇数

每个输入区间[a,b],首先判断a-1与b的根节点是否相同

a)如果相同表示(a-1,b]之间1的个数奇偶性已知s((a-1,b])=s[a-1]^s[b],此时只需简单判断即可

b)如果不同,我们需要合并两个子树,我们将root较大的子树(例root[a])合并到root较小的子树(例root[b]),且此时s[root[a]]=s[a]^s[b]^s((a-1,b])

在路径压缩的过程中s[i]=s[i]^s[root[i]],s[root[i]]为(root[root[i]], root[i]]区间内1个数的奇偶性,例(a, b]区间1的个数为偶数,(b, c]区间1的个数为奇数,(a, c]之间1的个数显然为0^1=1奇数

 

 

两个代码:

一个是直接用STL中的map写得,一个是自己写HASHMAP的

第二个效率比较高

 

/*
POJ 1733
用的 STL中的map + 并查集
*/

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string.h>
#include <map>
using namespace std;

const int MAXN=10010;
int F[MAXN];
int val[MAXN];
int find(int x)
{
    if(F[x]==-1)return x;
    int tmp=find(F[x]);
    val[x]^=val[F[x]];
    return F[x]=tmp;
}
map<int,int>mp;
int tol=0;
int insert(int x)
{
    if(mp.find(x)==mp.end())mp[x]=tol++;
    return mp[x];
}

int main()
{
    int n,m;
    int u,v;
    char str[20];
    while(scanf("%d%d",&n,&m)==2)
    {
        tol=0;
        memset(F,-1,sizeof(F));
        memset(val,0,sizeof(val));
        mp.clear();
        int ans=m;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%s",&u,&v,&str);
            if(u>v)swap(u,v);
            if(ans<m)continue;

            u=insert(u-1);
            v=insert(v);
            //printf("%d %d\n",u,v);

            int tmp;
            if(str[0]=='e')tmp=0;
            else tmp=1;
            int t1=find(u);
            int t2=find(v);


            if(t1==t2)
            {
                if(val[u]^val[v]!=tmp)ans=i;
            }
            else
            {
                F[t2]=t1;
                val[t2]=tmp^val[u]^val[v];
            }

        }
        printf("%d\n",ans);
    }
    return 0;
}

 

 

代码二:

/*
POJ 1733
HASH+并查集实现
*/
#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;

const int HASH=10007;
const int MAXN=10010;

struct HASHMAP
{
    int head[HASH];
    int next[MAXN];
    int size;
    int state[MAXN];
    void init()
    {
        size=0;
        memset(head,-1,sizeof(head));
    }
    int push(int st)
    {
        int i,h=st%HASH;
        for(i=head[h];i!=-1;i=next[i])
           if(state[i]==st)
             return i;
        state[size]=st;
        next[size]=head[h];
        head[h]=size++;
        return size-1;
    }
}hm;
int F[MAXN];
int val[MAXN];
int find(int x)
{
    if(F[x]==-1)return x;
    int tmp=find(F[x]);
    val[x]^=val[F[x]];
    return F[x]=tmp;
}

int main()
{
    int n,m;
    int u,v;
    char str[20];
    while(scanf("%d%d",&n,&m)==2)
    {
        hm.init();
        memset(F,-1,sizeof(F));
        memset(val,0,sizeof(val));
        int ans=m;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%s",&u,&v,&str);
            if(u>v)swap(u,v);
            if(ans<m)continue;

            u=hm.push(u-1);
            v=hm.push(v);
            //printf("%d %d\n",u,v);

            int tmp;
            if(str[0]=='e')tmp=0;
            else tmp=1;
            int t1=find(u);
            int t2=find(v);

            if(t1==t2)
            {
                if(val[u]^val[v]!=tmp)ans=i;
            }
            else
            {
                F[t2]=t1;
                val[t2]=tmp^val[u]^val[v];
            }

        }
        printf("%d\n",ans);
    }
    return 0;
}

 

posted on 2013-04-05 13:53  kuangbin  阅读(1326)  评论(0编辑  收藏  举报

导航

JAVASCRIPT: