POJ 2524 Ubiquitous Religions (最简单的并查集)

Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 19259   Accepted: 9460

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

Source

 
 
 
/*
POJ  2524
最简单的并查集的题目

*/

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;
const int MAXN=50010;
int F[MAXN];
int find(int x)
{
    if(F[x]==-1)return x;
    return F[x]=find(F[x]);
}
void bing(int u,int v)
{
    int t1=find(u);
    int t2=find(v);
    if(t1!=t2)F[t1]=t2;
}
int main()
{
    int n,m;
    int u,v;
    int iCase=0;
    while(scanf("%d%d",&n,&m)==2)
    {
        if(n==0 && m==0)break;
        iCase++;
        memset(F,-1,sizeof(F));
        while(m--)
        {
            scanf("%d%d",&u,&v);
            bing(u,v);
        }
        int ans=0;
        for(int i=1;i<=n;i++)
          if(F[i]==-1)
             ans++;
        printf("Case %d: %d\n",iCase,ans);
    }
    return 0;
}

 

posted on 2013-04-05 10:09  kuangbin  阅读(587)  评论(0编辑  收藏  举报

导航

JAVASCRIPT: