HDU 4288 Coder 第37届ACM/ICPC 成都赛区网络赛1001题 (线段树)

Coder

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 120    Accepted Submission(s): 52


Problem Description
  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done. 1
  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).
Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.
  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:
  1. add x – add the element x to the set;
  2. del x – remove the element x from the set;
  3. sum – find the digest sum of the set. The digest sum should be understood by

  where the set S is written as {a1, a2, ... , ak} satisfying a1 < a2 < a3 < ... < ak
  Can you complete this task (and be then fired)?
------------------------------------------------------------------------------
1 See http://uncyclopedia.wikia.com/wiki/Algorithm
 

 

Input
  There’re several test cases.
  In each test case, the first line contains one integer N ( 1 <= N <= 105 ), the number of operations to process.
  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.
  You may assume that 1 <= x <= 109.
  Please see the sample for detailed format.
  For any “add x” it is guaranteed that x is not currently in the set just before this operation.
  For any “del x” it is guaranteed that x must currently be in the set just before this operation.
  Please process until EOF (End Of File).
 

 

Output
  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.
 

 

Sample Input
9 add 1 add 2 add 3 add 4 add 5 sum add 6 del 3 sum 6 add 1 add 3 add 5 add 7 add 9 sum
 

 

Sample Output
3 4 5
Hint
C++ maybe run faster than G++ in this problem.
 

 

Source
 

 

Recommend
liuyiding
 
线段树的题目。
据说是CF原题。
这题网络赛原题太多了。
 
建立线段树。用离线处理。
每个区间s[5]和num分别表示5个和 以及  个数。
#include<stdio.h>
#include<iostream>
#include<map>
#include<algorithm>
#include<string.h>

using namespace std;
const int MAXN=100010;
struct Node
{
    int l,r;
    long long s[5];
    int num;
}segTree[MAXN*3];

map<long long,int>mp;

map<long long ,int>mp2;

long long a[MAXN];
void Build(int i,int l,int r)
{
    segTree[i].l=l;
    segTree[i].r=r;
    segTree[i].num=0;
    for(int j=0;j<5;j++)
       segTree[i].s[j]=0;
    if(l==r)
    {
        mp[a[l]]=i;
        return ;
    }
    int mid=((l+r)>>1);
    Build(i<<1,l,mid);
    Build((i<<1)|1,mid+1,r);
}
void add(long long x)
{
    int tt=mp[x];
    segTree[tt].num=1;
    segTree[tt].s[0]=x;
    tt>>=1;
    while(tt)
    {
        segTree[tt].num++;
        int temp=segTree[tt<<1].num;
        for(int i=0;i<5;i++)
         segTree[tt].s[i]=segTree[tt<<1].s[i];
        for(int i=0;i<5;i++)
          segTree[tt].s[(temp+i)%5]+=segTree[(tt<<1)|1].s[i];
        tt>>=1;
    }
}
void del(long long x)
{
    int tt=mp[x];
    segTree[tt].num=0;
    for(int i=0;i<5;i++)segTree[tt].s[i]=0;
    tt>>=1;
    while(tt)
    {
        if(segTree[tt].num>0)segTree[tt].num--;
        int temp=segTree[tt<<1].num;
        for(int i=0;i<5;i++)
         segTree[tt].s[i]=segTree[tt<<1].s[i];
        for(int i=0;i<5;i++)
          segTree[tt].s[(temp+i)%5]+=segTree[(tt<<1)|1].s[i];
        tt>>=1;
    }
}

struct action
{
    int id;
    long long x;
}node[MAXN];

char str[20];

int main()
{

    int n;
    int m;
    while(scanf("%d",&n)!=EOF)
    {
        m=0;

        for(int i=1;i<=n;i++)
        {
            scanf("%s",&str);
            if(strcmp(str,"add")==0)
            {
                node[i].id=0;
                scanf("%I64d",&node[i].x);
                a[++m]=node[i].x;
            }
            else if(strcmp(str,"sum")==0)
            {
                node[i].id=1;
            }
            else
            {
                node[i].id=2;
                scanf("%I64d",&node[i].x);
            }
        }
        a[++m]=0;
        sort(a+1,a+m+1);
        mp.clear();
        Build(1,1,m);
        mp2.clear();
        add(0);
        mp2[0]=1;
        for(int i=1;i<=n;i++)
        {
            if(node[i].id==0)
            {
                if(mp2[node[i].x]==0)
                {
                    mp2[node[i].x]=1;
                    add(node[i].x);
                }
            }
            else if(node[i].id==1)
            {
                printf("%I64d\n",segTree[1].s[3]);
            }
            else
            {
                if(mp2[node[i].x]==1)
                {
                    mp2[node[i].x]=0;
                    del(node[i].x);
                }
            }
        }
    }
    return 0;
}

 

posted on 2012-09-16 19:29  kuangbin  阅读(1294)  评论(0编辑  收藏  举报

导航

JAVASCRIPT: