junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35724    Accepted Submission(s): 16264


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
4 10 3
 

Author
lcy

题意:给一段数字,找出和最大且递增的子序列。

思路:类似LIS方程,简单改一下就行。

# include <stdio.h>
# include <algorithm>
# define INF 0x7fffffff
using namespace std;
int main()
{
    int n;
    long long a[1000], sum[1000], imax;
    while(~scanf("%d",&n),n)
    {
        imax = -INF-1;
        for(int i=0; i<n; ++i)
        {
            scanf("%lld",&a[i]);
            sum[i] = a[i];
        }
        for(int i=0; i<n; ++i)
        {
            for(int j=0; j<i; ++j)
                if(a[j]<a[i])
                    sum[i] = max(sum[i], sum[j]+a[i]);
            imax = max(imax, sum[i]);
        }
        printf("%lld\n",imax);
    }
    return 0;
}




posted on 2017-02-03 13:51  junior19  阅读(109)  评论(0编辑  收藏  举报