POJ1122_FDNY to the Rescue!(逆向建图+最短路树)

FDNY to the Rescue!
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 2368   Accepted: 721

Description

The Fire Department of New York (FDNY) has always been proud of their response time to fires in New York City, but they want to make their response time even better. To help them with their response time, they want to make sure that the dispatchers know the closest firehouse to any address in the city. You have been hired to write this software and are entrusted with maintaining the proud tradition of FDNY. Conceptually, the software will be given the address of the fire, the locations of the firehouses, street intersections, and the time it takes to cover the distance between each intersection. It will then use this information to calculate how long it takes to reach an address from each firehouse. 

Given a specific fire location in the city, the software will calculate the time taken from all the fire stations located in the city to reach the fire location. The list of fire stations will be sorted from shortest time to longest time. The dispatcher can then pick the closest firestation with available firefighters and equipment to dispatch to the fire.

Input

Line 1: 
# of intersections in the city, a single integer (henceforth referred to as N) N<20 

Lines 2 to N+1: 
A table (square matrix of integer values separated by one or more spaces) representing the time taken in minutes between every pair of intersections in the city. In the sample input shown below the value "3" on the 1st row and the 2nd column represents the time taken from intersection #1 to reach intersection #2. 

Similarly the value "9" on the 4th row and the 2nd column represents the time taken from intersection #4 to reach intersection #2. 

A value of -1 for time means that it is not possible to go directly from the origin intersection (row #) to the destination intersection (column #). All other values in the table are non-negative. 

Line N+2: 
An integer value n (<= N) indicating the intersection closest to the fire location followed by one or more integer values for the intersections closest to the fire stations (all on one line, separated by one or more spaces) will follow the input matrix. 

Notes on input format: 

1. The rows and columns are numbered from 1 to N. 
2. All input values are integers 
3. All fire locations are guaranteed reachable from all firehouses. 
4. All distance calculations are made from the intersection closest to each firehouse to the intersection closest to the fire. 

Output

Line 1: 
A label line with the headings for each column, exactly as shown in the example. 

Line 2 onwards (one line for each fire station): 
A sorted list (based on time) showing the fire station (origin), the destination site, time taken and a complete shortest path of nodes from the originating fire station to the fire location. 

Notes on output format: 
1. Columns are tab separated. 
2. If two or more firehouses are tied in time they can be printed in any order. 
3. If more than one path exists that has the same minimal time for a given location & firehouse, either one can be printed on the output. 
4. If the fire location and the fire station locations happen to be the same intersection, the output will indicate that the origin and destination have the same intersection number, the time will be "0" and the nodes in the shortest path will show just one number, the fire location. 
Next is the picture for the sample input data. 

Sample Input

6 
0  3  4 -1 -1 -1 
-1 0  4  5 -1 -1 
2  3  0 -1 -1  2 
8  9  5  0  1 -1 
7  2  1 -1  0 -1 
5 -1  4  5  4  0 
2  4  5  6 
In the above input the last line indicates that "2" is the location of the fire and "4", "5" and "6" are the intersections where fire stations are located. 

Sample Output

Org	Dest	Time	Path
5	2	2	5	2
4	2	3	4	5	2
6	2	6	6	5	2

Source

解题报告
下午RE了下午,莫名的心烦。。

。(心烦是不是下午模拟邀请赛挂零了。。。

晚上回宿舍又一次敲上一遍。AC。。

这题要处理建图的关系,尽管图是无向图,但i到j的时间并非j到i的时间,灭火大队又要从消防站出发到达火源,而火源是固定的。所以逆向建图是最好的处理。找从火源出发到达消防站的最短时间。
二是这题要打印路径,非常少碰到这类题目,事实上就是利用数组来处理树的关系。数组储存的是当前序号节点的父节点,一次找下去,就是遍历路径树。

当中处理最短路是最裸的最短路。

。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define inf 99999999
#define Max 30
using namespace std;
int n,mmap[Max][Max],dis[Max],vis[Max],pre[Max];
struct node
{
    int org,dest,time;
} num[Max];
int cmp(node a,node b)
{
    return a.time<b.time;
}
void dij(int s)
{
    int i,j,u,minn;
    for(i=1; i<=n; i++)
    {
        dis[i]=mmap[s][i];
        vis[i]=0;
        if(i!=s)
            pre[i]=s;
        else pre[i]=-1;
    }
    dis[s]=0;
    vis[s]=1;
    for(i=0; i<n-1; i++)
    {
        u=0;
        minn=inf;
        for(j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]<minn)
            {
                minn=dis[j];
                u=j;
            }
        }
        vis[u]=1;
        for(j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]>dis[u]+mmap[u][j])
            {
                dis[j]=dis[u]+mmap[u][j];
                pre[j]=u;
            }
        }
    }
}
int main()
{
    int i, j, s, u, cnt=0;
    cin>>n;
    for(i=1; i<=n; i++)
    {
        for(j=1; j<=n; j++)
        {
            scanf("%d",&mmap[j][i]);
            if(mmap[j][i]==-1)
                mmap[j][i]=inf;
        }
    }
    cin>>s;
    dij(s);
    while(cin>>u)
    {
        num[cnt].org=u;
        num[cnt].dest=s;
        num[cnt++].time=dis[u];
    }
    printf("Org\tDest\tTime\tPath\n");
    int shortest[Max];
    sort(num,num+cnt,cmp);
    for(i=0; i<cnt; i++)
    {
        printf("%d\t%d\t%d",num[i].org,num[i].dest,num[i].time);
        memset(shortest,0,sizeof(shortest));
        int k=0;
        shortest[k]=num[i].org;
        while(pre[shortest[k]]!=-1)
        {
            k++;
            shortest[k]=pre[shortest[k-1]];
        }
//        k++;
//        shortest[k]=s;
        for(j=0;j<=k;j++)
        printf("\t%d",shortest[j]);
        printf("\n");
    }
    return 0;
}


posted @ 2017-07-31 08:01  jhcelue  阅读(237)  评论(0编辑  收藏  举报