POJ 2823 Sliding Window

Sliding Window
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 54931   Accepted: 15815
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

 
 
 
解析:单调队列。
 
 
注意编译器选择C++(C++ AC,G++ TLE)
#include <cstdio>
#include <utility>
using namespace std;

const int MAXN = 1e6+5;
int n, k;
int a[MAXN];
pair<int, int> q[MAXN];
int res_min[MAXN], res_max[MAXN];

void get_min()
{
    int l = 0, r = 0;
    int i;
    for(i = 0; i < k-1; ++i){
        while(l < r && a[i] <= q[r-1].first)
            --r;
        q[r].first = a[i];
        q[r++].second = i;
    }
    int cnt = 0;
    for(; i < n; ++i){
        while(l < r && a[i] <= q[r-1].first)
            --r;
        q[r].first = a[i];
        q[r++].second = i;
        while(q[l].second < i-k+1)
            ++l;
        res_min[cnt++] = q[l].first;
    }
    for(i = 0; i < cnt-1; ++i)
        printf("%d ", res_min[i]);
    printf("%d\n", res_min[cnt-1]);
}

void get_max()
{
    int l = 0, r = 0;
    int i;
    for(i = 0; i < k-1; ++i){
        while(l < r && a[i] >= q[r-1].first)
            --r;
        q[r].first = a[i];
        q[r++].second = i;
    }
    int cnt = 0;
    for(; i < n; ++i){
        while(l < r && a[i] >= q[r-1].first)
            --r;
        q[r].first = a[i];
        q[r++].second = i;
        while(q[l].second < i-k+1)
            ++l;
        res_max[cnt++] = q[l].first;
    }
    for(i = 0; i < cnt-1; ++i)
        printf("%d ", res_max[i]);
    printf("%d\n", res_max[cnt-1]);
}

void solve()
{
    get_min();
    get_max();
}

int main()
{
    scanf("%d%d", &n, &k);
    for(int i = 0; i < n; ++i)
        scanf("%d", &a[i]);
    solve();
    return 0;
}

 运用Java的双端队列,写法如下:

import java.util.ArrayDeque;
import java.util.Deque;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        int k = sc.nextInt();
        int[] a = new int[n];
        for (int i = 0; i < n; ++i) {
            a[i] = sc.nextInt();
        }
        get(a, n, k, true);
        get(a, n, k, false);
        sc.close();
    }

    private static void get(int[] a, int n, int k, boolean le) {
        int[] res = new int[n - k + 1];
        int cnt = 0;
        Deque<Integer> deque = new ArrayDeque<Integer>();
        int i;
        for (i = 0; i < k - 1; ++i) {
            while (!deque.isEmpty() && cmp(a[i], a[deque.peekLast()], le)) {
                deque.pollLast();
            }
            deque.offerLast(i);
        }
        for (; i < n; ++i) {
            while (!deque.isEmpty() && cmp(a[i], a[deque.peekLast()], le)) {
                deque.pollLast();
            }
            deque.offerLast(i);
            while (i - deque.peekFirst() > k - 1) {
                deque.pollFirst();
            }
            res[cnt++] = a[deque.peekFirst()];
        }
        System.out.print(res[0]);
        for (i = 1; i < res.length; ++i) {
            System.out.print(" " + res[i]);
        }
        System.out.println();
    }

    private static boolean cmp(int a, int b, boolean le) {
        return le ? a <= b : a >= b;
    }
}

  

 

posted on 2016-09-07 21:08  月夜下  阅读(158)  评论(0编辑  收藏  举报

导航

"320px">