HDU 1003:Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 199419    Accepted Submission(s): 46633


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:  1176 1087 1069 2084 1203 
 

迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

#include <iostream>
using namespace std;
int main()
{
    int T,N,n,j =1;
    cin >> T;
    while (T--)
    {
        int max = -1001,sum = 0,temp = 1,first,second;
        cin >> N;
        int *p = new int(N);
        for (int i = 1; i <= N; i++)
        {
            cin >> n;
            sum += n;
            if (max < sum)
            {
                max = sum;
                first = temp;
                second = i;
            }
            if (sum < 0)
            {
                sum = 0;
                temp = i +1;
            }
        }
        cout << "Case " << j++ << ":" << endl;
        cout << max << " " << first << " " << second << endl;
        if(T)cout << endl;
        delete p;
    }
    return 0;
}


posted @ 2016-03-01 18:52  小坏蛋_千千  阅读(125)  评论(0编辑  收藏  举报