Plugin 'Lombok Plugin' is incompatible with this installation

作者:13
GitHub:https://github.com/ZHENFENG13
版权声明:本文为原创文章,未经允许不得转载。

Installation Error

Plugin 'Lombok Plugin' is incompatible with this installation

这段错误的意思是:Lombok插件版本与IDEA版本不兼容导致无法安装,如图:

incompatible-version

当然,出现这个问题的不止是Lombok插件,也有可能是其他的插件或者工具包,出现版本不兼容的问题都会无法正常安装。

问题描述

当时的情形是IDEA编辑器无法正常下载安装Lombok插件:

download-lombok

在IDEA的Plugins界面搜索插件并下载,但是始终没有任何反应,在半分钟左右的请求等待后IDEA编辑器中直接出现了错误提示弹窗,如下:

faild-download

通过上图可以看到,提示也很清楚,就是无法下载!之后又把这个过程反复尝试了有三次,但是得到的结果都是相同的,之后又尝试了其他的方案,但是都无法正常安装这个插件,具体原因不太清楚,但是估计与网络有很大的关系,可能是被墙了,或者是刚好那天网络发神经,总之就是无论如何都安装不了这个插件。

由于无法通过插件仓库下载安装,于是想着通过本地下载并install的方式来把Lombok安装到IDEA编辑器中,这个错误就是十三在进行本地安装Lombok插件时导致的,由于下载了错误版本的插件包导致了这个问题。

解决方案

由于下载的插件包版本错误,那么就需要找到正确版本的插件包下载,十三一开始觉得下载最新版本的就可以了,准没错,打脸的结果就是安装不了。

首先就是确定自己的IDEA版本,打开IDEA的安装目录可以看到IDEA的版本信息,如图所示:

idea-version

可以看到十三安装的IDEA版本为2017.3.3,因此需要安装对应的Lombok插件版本也是2017.3.3,而不是最新版的lombok-plugin-0.17-2018.1。

下载到本地后,依次进入IDEA-->Settings/Preferences-->Plugins

install-from-disk

在Plugins面板中有'install from disk'按钮,点击后选择下载的lombok-plugin-0.16-2017.3.3.zip文件即可,安装成功,过程如下:

install-from-disk

版本正确后再次安装,标题中的错误没有出现。

总结

十三总结这篇文章的原因,是因为在遇到这个安装问题后,也曾经尝试在网上找答案,但是没有找到,因此就自己整理了这篇文章,希望以后碰到类似问题的朋友可以很快的解决掉这种小问题。

首发于我的个人博客.

相关文章:
IDEA安装Lombok插件失败的解决方案
如何查看IntelliJ IDEA的版本信息

end

posted @ 2018-06-12 11:30 涵s 阅读(...) 评论(...) 编辑 收藏