关于jstl在tomcat5和tomcat6的部署

2008-12-04 12:09

关于jstl在tomcat5和tomcat6的部署

转自:http://hi.baidu.com/zh_m_zhou/blog/item/c7b4eecd7d15c11700e9285a.html
作者:Pocky

昨天,写了个测试项目,只用到了el表达式和jstl,在tomcat6.0上跑得好好的,没想到copy后,被告知跑不起来。结果发现是tomcat版本的问题。查阅了不少资料,现在总结如下:

错误信息: java.lang.NoClassDefFoundError: javax/el/ExpressionFactory

分析:少包,上网查阅后发现解决方法

解决方法:将javaee.jar包再copy一份放在tomcat目录的common\lib下

如上完成后即解决了该异常,大以为大功告成,没想到又出现了新异常

错误信息:java.lang.NoSuchMethodError: javax.servlet.JSP.PageContext.getELContext()LJAVAx/el/ELContext

分析:这个问题网上找了半天没看到解决方法,只好自己想办法。想起先前看到的一个知识点:tomcat 6 实现了 servlet 2.5 和JSP2.1的规范相应的 tomcat 5 实现的是 2.4和2.0,想到tomcat5不支持JSTL1.2,于是替换JSTL1.1的包试试看后,问题解决

解决方法:移出工程lib目录中的JSTL1.2.jar,添加standard-1.1.jar和JSTL1.1.jar

总结:

jstl1.1版本由2个必要包构成:standard-1.1.jar和JSTL1.1.jar;而jstl1.2版本只有一个必要包JSTL1.2.jar。(一开始在替换的过程中想当然的用JSTL1.1.jar换JSTL1.2.jar,然后遗漏了standard-1.1.jar,耽搁了不少时间。)

经测试,tomcat6.0支持JSTL1.2版本,也支持JSTL1.1版本;tomcat5.5只支持JSTL1.1(JSTL1.1一下版本未测试)

不建议将2个版本的3个包同时放在工程中,可能会发生版本冲突。(另外,实际操作的时候发现JSTL1.2.jar和JSTL1.1.jar这2个包放一起可以在tomcat5.5和tomcat6.0上跑,鉴于JSTL1.1.jar里面没有c.tld等文件,猜测JSTL1.1.jar里面只是放置了1.1的专用的类和信息)

最后,诚挚感谢.liujia MM的耐心帮助...^_^

posted @ 2013-05-03 11:31 眉间尺之魂 阅读(...) 评论(...) 编辑 收藏