1005 -- I Think I Need a Houseboat

I Think I Need a Houseboat
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 105186   Accepted: 45827

Description

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion. 

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.) 

Input

The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

Output

For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”

Sample Input

2
1.0 1.0
25.0 0.0

Sample Output

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

Hint

1.No property will appear exactly on the semicircle boundary: it will either be inside or outside. 
2.This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines. 
3.All locations are given in miles.
 
 
首先我们来理解一下题意: 有个大款,要在路易斯安那州买点地来建房子,但是好死不死呢,因为密西西比河一直在侵蚀,路易斯安那州每年都要缩小50平方英里。然后这个傻大款呢,就是要在这里买。然后啊,他研究发现,土地是以半圆的方式在流失着,就如图所示,以(0,0)为中心,有个半圆,X轴以下就是水。现在随便选一个坐标,然后求出,啥时候会淹到那,取整。
 
好,开始解题。
每年缩小50,先算出选中的坐标构成的半圆面积多大,然后除以50,取整 + 1 ,为什么加1? 看题目, The semicircle has an area of 0 at the beginning of year 1 。 
输入: 第一个为组数,就是下面要接受多少组数据,每组数据两个值,X,Y值。
2
1.0 1.0
25.0 0.0
输出:
Property 1: This property will begin eroding in year 1.   
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.
 
通过代码:
 

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int count = scanner.nextInt();
for(int i=0;i<count;i++){
double x = scanner.nextDouble();
double y = scanner.nextDouble();
double r = Math.sqrt(x*x + y*y);
int year = (int)((Math.PI * r*r * 0.5))/50 + 1;
System.out.println("Property "+(i+1)+": This property will begin eroding in year "+year+".");
}
System.out.println("END OF OUTPUT.");
}
}

 
Accepted 3244K 157MS Java 500B
posted @ 2017-09-07 10:30  Dino林  阅读(139)  评论(0编辑  收藏  举报