[iOS]让Xcode 4.2生成的app支持老的iOS设备(armv6)

这几天遇到一个非常奇怪的问题,基于Xcode 4.2开发的app,导出的ipa安装包不能安装到iPod Touch 2上。Touch2固件版本是4.2.1,已越狱。iTunes、91手机助手、同步推试过了都不行。但是其他ipa文件可以成功安装到Touch2上。而Xcode 4.2生成的ipa包在iPhone 4、iPhone 3GS、iPod Touch 4都能安装成功并顺利运行,无论固件什么版本。初步分析的结果就是Xcode 4.2生成的app不支持Touch2。这几天找了一些朋友帮我测试ipa安装包,问一些有iOS开发经验的朋友,最终有个朋友提醒我Xcode 4.2中,Project->Build Settings->Architectures->Release设置有关,经过修改,问题终于解决了,谢谢这位朋友!

原因分析:Xcode 4.2的Architectures设置默认只有armv7,也就是新的iOS设备,包括iPhone 3GS, iPhone 4, iPhone 4s, iPad, iPad2等,而iPhone, iPhone 3G, iPod Touch, iPod Touch 2属于armv6架构。

解决方法:将Architectures设置为armv6 armv7,如下图所示:

修改前:


修改后:

这样设置后生成的ipa安装包就可以支持老的iOS设备了。


另外,还要把Info设置中的Required device capabilitiess删掉,这样提交到AppStore后才会正确显示兼容老的iOS设备。


作者:黎波
博客:http://bobli.cnblogs.com/
日期:2011年11月9日

posted @ 2011-11-09 13:37 黎波 阅读(...) 评论(...) 编辑 收藏