HDU--2020

绝对值排序

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51632    Accepted Submission(s): 24938


Problem Description
输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。
 

Input
输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。
 

Output
对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。
 

Sample Input
3 3 -4 2 4 0 1 2 -3 0
 

Sample Output
-4 3 2 -3 2 1 0
 

Author
lcy

#include <iostream>
#include <cmath>

using namespace std;

int main()
{
	int n, a[110], t;
	while (cin >> n && n)
	{
		for (int i=0; i<n; i++)
		{
			cin >> a[i];
		}
		for (int i=0; i<n-1; i++)
		{
			for (int j=1; j<n-i; j++)
			{
				if (abs(a[j]) > abs(a[j-1]))
				{
					t= a[j];
					a[j] = a[j-1];
					a[j-1] = t;
				}
			}
		}
		cout << a[0];
		for (int i=1; i<n; i++)
		{
			cout << " "<< a[i] ;
		}
		cout<< endl;
	}
	return 0;
} 

用到了冒泡排序
posted @ 2015-05-26 20:51  Tovi  阅读(137)  评论(0编辑  收藏  举报