[解题报告]HDU 1008 Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30095    Accepted Submission(s): 16272


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

 

Output
Print the total time on a single line for each test case. 
 

 

Sample Input
1 2 3 2 3 1 0
 

 

Sample Output
17 41
 

 

Author
ZHENG, Jianqiang
 

 

Source
 

 

Recommend
JGShining
 
 
 
知道这一题最贱的地方在哪里么?
不是所有的输入都要小于100,
而是你连续输入相同的楼层也要算时间。。。。
比如
输入2 1 1要输出16而不是11
 
#include<stdio.h>
int main()
{
  int n;
  while(scanf("%d",&n)!=EOF&&n&&n<100)
  {
      int a[n];
      int i;
      for(i=0;i<n;i++)
        {
        scanf("%d",&a[i]);
        if(a[i]>=100) return 0;
        }
      int sum;
      sum=a[0]*6+5;
      for(i=0;i<n-1;i++)
      {
          if(a[i+1]>a[i]) sum+=(a[i+1]-a[i])*6+5;
          if(a[i+1]<a[i]) sum+=(a[i]-a[i+1])*4+5;
          if(a[i+1]==a[i]) sum+=5;
      }
      printf("%d\n",sum);
  }
  return 0;
}

 

posted @ 2013-03-13 21:25  三人木君  阅读(4088)  评论(0编辑  收藏  举报