HDU1003MAX SUM (动态规划求最大子序列的和)

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 206582    Accepted Submission(s): 48294


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 

 

Author
Ignatius.L
 

 

Recommend
We have carefully selected several similar problems for you:  1176 1087 1069 1058 1159 
题意:求连续子序列和的最大值。
题解: 注意这道题要求是输出第一个符合条件的序列,而且存在负数,样例之间要用空行分隔。
#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int a[maxn],n;
int main()
{
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int sum=0,ans=-1005;
        int s=1,e=1,k=1;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
            if(sum>ans)
            {
                s=k;
                e=i;
                ans=sum;
            }
            if(sum<0) //0的意义就是这段数做的是负功
            {
                sum=0;
                k=i+1;
            }
        }
        printf("Case %d:\n",cas++);
        printf("%d %d %d\n",ans,s,e);
        if(t>0) puts("");
    }
    return 0;
}

 

#include <bits/stdc++.h>
using namespace std;
const int N=1e5+5;
int a[N],n;
int main()
{
    int t,cas=1;
    cin>>t;
    while(t--)
    {
        cin>>n;
        int sum=0,mx=-1005,s=1,e=1,ts=1;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
            sum+=a[i];
            if(sum>mx)
            {
                mx=sum;
                s=ts;
                e=i;
            }
            if(sum<0)
            {
                sum=0;
                ts=i+1;
            }
        }
        printf("Case %d:\n",cas++);
        printf("%d %d %d\n",mx,s,e);
        if(t) printf("\n");
    }
    return 0;
}
/*
100
2 1 2
1 1
3 -1 1 2
2 -7 3
*/

 牢记顺序是 加 大于 小于!!

posted @ 2016-04-23 19:13  Ritchie丶  阅读(219)  评论(0编辑  收藏  举报