HD1004Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58555 Accepted Submission(s): 21498

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5 green red blue red red 3 pink orange pink 0

Sample Output

red pink

 

用map,简单易懂

#include<iostream>
#include<map>
#include<string>
using namespace std;
int main(){
    int n;
    while(cin>>n,n){
        map<string, int> counters; 
        string s;
        while(n--){       
            cin >> s ; 
            ++counters[s];            
        }
        map<string, int>::const_iterator it = counters.begin(),j = counters.begin();
        for (;it != counters.end(); ++it) {
            if(it->second > j->second)
                j = it;
            }
        cout<<j->first<<endl;
    }
    return 0;
}

 

在讨论区里看到有人用了clear(),不知效率会不会高一些,大神鉴定一下,代码大概是这样(ac了的)

#include<iostream>
#include<map>
#include<string>
using namespace std;
int main(){
    int n;
    map<string, int> counters; 
    string s;
    
    while(cin>>n,n){
        int max = 1;
        while(n--){    
            cin >> s ; 
            ++counters[s];
            if(counters[s] > max)
                max = counters[s];
        }
        map<string, int>::const_iterator it = counters.begin();
        for (;it != counters.end(); ++it) {
            if(it->second == max)
                cout<<it->first<<endl;
            }
        counters.clear();
    }
    return 0;
}
posted @ 2013-08-20 15:45  兰幽  阅读(228)  评论(0编辑  收藏  举报