POJ 3034 Whac-a-Mole



Whac-a-Mole
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 3070Accepted: 922

Description

POJ 3034 Whac-a-Mole - qhn999 - 码代码的猿猿

While visiting a traveling fun fair you suddenly have an urge to break the high score in the Whac-a-Mole game. The goal of the Whac-a-Mole game is to… well… whack moles. With a hammer. To make the job easier you have first consulted the fortune teller and now you know the exact appearance patterns of the moles.

The moles appear out of holes occupying the n2 integer points (xy) satisfying 0 ≤ xy < n in a two-dimensional coordinate system. At each time step, some moles will appear and then disappear again before the next time step. After the moles appear but before they disappear, you are able to move your hammer in a straight line to any position (x2y2) that is at distance at most d from your current position (x1y1). For simplicity, we assume that you can only move your hammer to a point having integer coordinates. A mole is whacked if the center of the hole it appears out of is located on the line between (x1y1) and (x2y2) (including the two endpoints). Every mole whacked earns you a point. When the game starts, before the first time step, you are able to place your hammer anywhere you see fit.

Input

The input consists of several test cases. Each test case starts with a line containing three integers nd and m, where n and d are as described above, and m is the total number of moles that will appear (1 ≤ n ≤ 20, 1 ≤ d ≤ 5, and 1 ≤ m ≤ 1000). Then follow m lines, each containing three integers xy and t giving the position and time of the appearance of a mole (0 ≤ xy < n and 1 ≤ t ≤ 10). No two moles will appear at the same place at the same time.

The input is ended with a test case where n = d = m = 0. This case should not be processed.

Output

For each test case output a single line containing a single integer, the maximum possible score achievable.

Sample Input

4 2 6
0 0 1
3 1 3
0 1 2
0 2 2
1 0 2
2 0 2
5 4 3
0 0 1
1 2 1
2 4 1
0 0 0

Sample Output

4
2

Source

Nordic 2006 


可以从任意位置开始,移动到距离小于等于d的整数点上,打掉在这条直线上的地鼠。。。
锤子可以移动到格子外面。。。。。坑爹啊。。。


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int map[40][40][20],dp[40][40][20],n,m,d;

int ABS(int x)
{
    if(x<0return -x;
    return x;
}

int GCD(int a,int b)
{
    if(a==0return b;
    return GCD(b%a,a);
}

int getsum(int x1,int y1,int x2,int y2,int t)
{
    int dx=x2-x1,dy=y2-y1;
    if(dy*dy+dx*dx>d*d) return 0;
    int sum=0,gc;
    if(dx==0&&dy==0return map[x1][y1][t];
    if(ABS(dx)>ABS(dy))
        gc=GCD(ABS(dy),ABS(dx));
    else
        gc=GCD(ABS(dx),ABS(dy));
    dx=dx/gc; dy=dy/gc;///GCD的妙用。。。。
    for(int i=0;i<=gc;i++)
        sum+=map[x1+i*dx][y1+i*dy][t];
    return sum;
}

int main()
{
    while(scanf("%d%d%d",&n,&d,&m)!=EOF&&(n||d||m))
    {
        memset(map,0,sizeof(map));
        memset(dp,0,sizeof(dp));
        int ans=0,mt=1;
        for(int i=1;i<=m;i++)
        {
            int x,y,t;
            scanf("%d%d%d",&x,&y,&t);
            map[x+d][y+d][t]++;
            mt=max(mt,t);
        }
        n=n+2*d;
        for(int t=1;t<=mt;t++)
        {
            for(int x=0;x<n;x++)
            {
                for(int y=0;y<n;y++)
                {
                    int sx=(x-d)>0?x-d:0;
                    int tx=(x+d)<n?x+d:n-1;
                    int sy=(y-d)>0?y-d:0;
                    int ty=(y+d)<0?y+d:n-1;
                    for(int i=sx;i<=tx;i++)
                    {
                        for(int j=sy;j<=ty;j++)
                        {
                            if(((i-x)*(i-x)+(j-y)*(j-y))-d*d>0continue;
                            dp[x][y][t]=max(dp[x][y][t],getsum(i,j,x,y,t)+dp[j][t-1]);
                        }
                    }
                if(t==mt)
                    ans=max(ans,dp[x][y][t]);
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
* This source code was highlighted by YcdoiT. ( style: Codeblocks )
posted @ 2013-09-20 01:28  码代码的猿猿  阅读(269)  评论(0编辑  收藏  举报