刷题总结——Aeroplane chess(hdu4405)

题目:

Problem Description

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.

Input

There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 

Output

For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.

Sample Input

2 0 8 3 2 4 4 5 7 8 0 0

Sample Output

1.1667 2.3441

题解:

  期望dpsb题···不多说了

代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<ctime>
#include<cctype>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e5+5;
double f[N];
int n,m,to[N];
inline int R(){
    char c;int f=0;
    for(c=getchar();c<'0'||c>'9';c=getchar());
    for(;c<='9'&&c>='0';c=getchar())    f=(f<<3)+(f<<1)+c-'0';
    return f;
}
int main(){
    //freopen("a.in","r",stdin);
    while(scanf("%d%d",&n,&m)){
        if(n==0&&m==0)    break;
        memset(to,0,sizeof(to));memset(f,0,sizeof(f));int a,b;
        for(int i=1;i<=m;i++)    a=R(),b=R(),to[a]=b;
        for(int i=n-1;i>=0;i--){
            if(to[i]){
                f[i]=f[to[i]];continue;
            }
            for(int j=1;j<=6;j++)
                f[i]+=(f[i+j]+1)/6;
        }
        printf("%0.4f\n",f[0]);
    }
    return 0;
}

 

 

posted @ 2017-11-01 21:44  AseanA  阅读(233)  评论(0编辑  收藏  举报