【48.51%】【poj 1611】The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 34447 Accepted: 16711
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1
Source

Asia Kaohsiung 2003

【题解】

把每一组都合并在一起。以第一个元素作为“代表”。然后这个代表所在的域记录了这个集合的大小。
合并的时候把大小累加到另外一个集合的代表域上就可以了。(儿子加到爸爸上面);
一开始大小为1;
最后输出那个包括0的集合的大小就好

#include <cstdio>
#include <iostream>

using namespace std;

const int MAXN = 39000;

int n, m;
int f[MAXN], cnt[MAXN] = { 0 };

void input(int &r)
{
    char t;
    t = getchar();
    while (!isdigit(t)) t = getchar();
    r = 0;
    while (isdigit(t))
    {
        r = r * 10 + t - '0';
        t = getchar();
    }
}

int findfather(int x)
{
    if (f[x] == x)
        return x;
    else
        f[x] = findfather(f[x]);;
    return f[x];
}

int main()
{
    //freopen("F:\\rush.txt", "r", stdin);
    input(n); input(m);
    while ((n + m) != 0)
    {
        for (int i = 0; i <= n-1; i++)
            f[i] = i,cnt[i] = 1;
        int num = n;
        for (int i = 1; i <= m; i++)
        {
            int x, y,pre;
            input(x);
            if (x > 0)
                input(pre);
            for (int i = 2; i <= x; i++)
            {
                input(y);
                int a = findfather(pre), b = findfather(y);
                if (a != b)
                {
                    f[b] = a;
                    cnt[a] += cnt[b];
                }
            }
        }
        printf("%d\n", cnt[findfather(0)]);
        scanf("%d%d", &n, &m);
    }
    return 0;
}
posted @ 2017-10-06 19:23  AWCXV  阅读(71)  评论(0编辑  收藏  举报