poj2533——lis(最长上升子序列), 线性dp

poj2533——lis(最长上升子序列), 线性dp

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 36143   Accepted: 15876

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
题意:求lis思路:dp[i]=max{dp[i],dp[j]+(a[i]>a[j])},ans=max{dp[i]},注意是dp[i]的最大值而不是dp[N]
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>

using namespace std;

const int maxn=1000100;
int N;
int a[maxn];
int dp[maxn];

int main()
{
    scanf("%d",&N);
    for(int i=1;i<=N;i++){
        scanf("%d",&a[i]);
        dp[i]=1;
    }
    for(int i=2;i<=N;i++){
        for(int j=1;j<i;j++){
            if(a[j]<a[i]) dp[i]=max(dp[i],dp[j]+1);
        }
    }
    int ans=1;
    for(int i=1;i<=N;i++){ //注意并不是dp[N]最大,而是要找出dp[i]的最大值才是答案,不理解就打表
        if(dp[i]>ans) ans=dp[i];
    }
    printf("%d\n",ans);
    return 0;
}
View Code

 

posted @ 2015-03-20 18:17  __560  阅读(199)  评论(0编辑  收藏  举报